Login to WorkCenter requires Internet Explorer browser. Please switch to Internet Explorer. Internet Explorer Browser versions 8, 9, 10, 11 in compatibility view are supported.